MEO tv box not working - Broadband Internet, Wifi, Phone and TV in Silves - Silves forum - Algarve forum in the Southern Portugal province of Portugal

Join the Silves forum

Join the Silves forumMy name's Alex and this is my website all about Silves in Portugal. Register now for free to talk about Broadband Internet, Wifi, Phone and TV in Silves and much more!

MEO tv box not working

Posted: Sun Jun 5, 2022 10:28am
7 replies48 views5 members subscribed
aspidistra

Posts: 52

9 helpful points

Location: Silves

Joined: 8 Aug 2021

Anyone know what the best thing to do to restart a MEO tv box is? The internet is working okay but the MEO box is staying with the red button on and the TV saying it's not connected. Checked all the wires, okay, will it mess anything up if I unplug and replug it in the hope that restarts it? Only had it a couple of weeks and was working ojah

Jbg

Posted: Sun Jun 5, 2022 4:45pm

Jbg

Posts: 2

1 helpful points

Location: Santa Luzia

Joined: 5 May 2022

Posted: Sun Jun 5, 2022 4:45pm

i have exactly the same problem, don't go to the shop they will do nothing

you have to call a technician and you need a portuguese number of phone otherwise they won't call you back......

that mean it doesn't work for me since 2 months

aspidistra

Posted: Sun Jun 5, 2022 5:18pm

aspidistra

Original Poster

Posts: 52

9 helpful points

Location: Silves

Joined: 8 Aug 2021

Posted: Sun Jun 5, 2022 5:18pm

Oh no. I also don’t have a PT phone number, so many things don’t work without one.

Gizmo

Posted: Sun Jun 12, 2022 9:08am

Posts: 3

1 helpful points

Joined: 25 Feb 2020

Posted: Sun Jun 12, 2022 9:08am

You can try unplugging it, and unplug the internet router too. It doesn’t mess anything up as it’s just the same as a power cut. If that doesn’t fix the problem you will need to ring Meo for a technician to come out. They must have had a way to contact you when you had the installation done so use the same way now 

Jbg

Posted: Sun Jun 12, 2022 1:07pm

Jbg

Posts: 2

1 helpful points

Location: Santa Luzia

Joined: 5 May 2022

Posted: Sun Jun 12, 2022 1:07pm

thank you , i tried to unplugg everything , but with no results ,  i'll call a technician but wish me good luck

lindsay

Posted: Sun Jun 12, 2022 1:58pm

Posts: 19

3 helpful points

Joined: 3 May 2020

Posted: Sun Jun 12, 2022 1:58pm

They can often do a lot of resets remotely when you are on the phone, just be prepared to sit by the box for an hour whilst they try all the options. 

Ian28

Posted: Mon Jun 13, 2022 3:07pm

Posts: 30

6 helpful points

Location: Salir

Joined: 20 Nov 2020

Posted: Mon Jun 13, 2022 3:07pm

Hi,

For me I had a similar problem and it was the white (rj45) 'phone' cable had come loose from the small box on the wall -  while I was switching everything back on after a long trip back home.

It needs to go in and 'click' in place to make full contact at both ends.

I called the helpdesk but they could not help (as the cable was not connected to the box correctly).

The same engineer who installed everything first time called me next day and came out to fix it.

He advised to just call him (the engineer) directly to make the appointments next time - as he had to come out from Olhao to Salir (~45-50 minutes drive) for me and had been in Loule (~15 min drive) the day before, so could have passed by earlier.

    [ I do have a Portuguese mobile phone  -  so don't know about the need for one ].

I hope this helps

Ian

aspidistra

Posted: Mon Jun 13, 2022 6:39pm

aspidistra

Original Poster

Posts: 52

9 helpful points

Location: Silves

Joined: 8 Aug 2021

Posted: Mon Jun 13, 2022 6:39pm

Ian28 wrote on Mon Jun 13, 2022 3:07pm:

Hi,

For me I had a similar problem and it was the white (rj45) 'phone' cable had come loose from the small box on the wall -  while I was switching everything back on after a long trip back home.

It needs to go in and 'click' in place to make full contact at both ends.

I called the helpdesk but they could not help (as the cable was not connected to the box correctly).

The same engineer who installed everything first time called me next day and came out to fix it.

He advised to just call him (the engineer) directly to make the appointments next time - as he had to come out from Olhao to Salir (~45-50 minutes drive) for me and had been in Loule (~15 min drive) the day before, so could have passed by earlier.

    [ I do have a Portuguese mobile phone  -  so don't know about the need for one ].

I hope this helps

Ian

Thanks everyone for your help on this. I have had to leave it for now, I unplugged everything and am hoping it resets okay on re-plugging next time, eeek!

Sign up for free or login to reply to this topic

Want to reply to this topic? Login or register for free to post your message:

Find more Broadband Internet, Wifi, Phone and TV topics from a particular area:


Register for free!

Login to your account

Advertise your business here
Help with my computer